Rename GridCoordinates to GridCoordinate

Description

GridCoordinates (plural form) is misnamed. It should be GridCoordinate (singular form). ISO 19123 is a little bit confusing on this topic since the document uses both CV_GridCoordinate and CV_GridCoordinates in UML and textual descriptions. But the later seems to be a typo. The section which describes specifically this class has a title in the singular form.

Furthermore GridCoordinate is consistent with ISO 19107 usage, which uses the singular form for a tuple of ordinates. The plural form would be for a collection of ordinate tuples.

Environment

None

Status

Assignee

Unassigned

Reporter

codehaus

Priority

Low
Configure