Rename CurveSegement.getCurve() to .getContainingCurve()

Description

The method should be renamed to better explain the purpose of the method. ".getCurve()" is a bit too vague to explain what it does; ISO 19107 explicitly allows profiles of the spec to use CurveSegments outside of containing Curves. "Containing" unfortunately is a long piece, perhaps we can find a better name.

Environment

None

Status

Assignee

Unassigned

Reporter

codehaus

Priority

Medium
Configure