Consider renaming createOperation(sourceCRS, targetCRS) as findOperation(...)

Description

The following methods:

  • CoordinateOperationFactory.createOperation(CoordinateReferenceSystem sourceCRS, CoordinateReferenceSystem targetCRS)
    * CoordinateOperationFactory.createOperation(CoordinateReferenceSystem sourceCRS, CoordinateReferenceSystem targetCRS, OperationMethod method)

are actually not for creating new coordinate operations from user-supplied parameters, but rather for letting the implementation figure out by itself a transformation path from sourceCRS to targetCRS. Consequently findOperation would be a better method name.

This renaming become more important since the addition of new createFoo(Map... methods, which really use directly the supplied parameters for creation new operations. Basically, every methods that doesn't have a Map<String,?>> as their first parameter are not really "create" methods.

Environment

None

Status

Assignee

Unassigned

Reporter

codehaus

Priority

Low
Configure