Transactions do not work with Postgres 7.4

Description

When a feature table in PostGis have a numeric column, the creation of the corresponding GeoServer Feature Type fails with NoSuchElementException when you press Apply or save or load your definitions. The trace takes me to org/vfny/geoserver/global/Data.java (982):

if (ftype == null)
{
throw new NoSuchElementException(
"there is no FeatureTypeConfig named " + typeName
+ " configured in this server");
}

If the table does not have numeric columns (i.e. drop them), all is fine.

Environment

None

Activity

Show:
codehaus
April 10, 2015, 3:56 PM

CodeHaus Comment From: cholmes - Time: Wed, 7 Apr 2004 09:18:38 -0500
---------------------
<p>could not replicate this error. Do you have a dump of the table you used to get

this? And what os/servlet container are you using? And what version of postgis?

I tested with this table:

CREATE TABLE chiang_mai {

gid integer,

length numeric,

name character_varying,

the_geom geometry,

CONSTRAINT "$1" CHECK ((srid(the_geom) = -1)),

CONSTRANT "$2" CHECK (((geometrytype(the_geom) - 'POINT'::text)

OR (the_geom IS NULL)))

);</p>

<p>And then I also tried one with numeric (32,4).</p>

<p>I'm testing with win xp, jetty and postgis 7.4</p>

<p>And do you have a more complete stack trace, with exactly what you filled in for all the values?</p>

codehaus
April 10, 2015, 3:56 PM

CodeHaus Comment From: cholmes - Time: Sun, 18 Apr 2004 09:47:47 -0500
---------------------
<p>Tried to reproduce this to no avail. If you can give more information then open it back up, stack traces, logs, table creation scripts, ect.</p>

Assignee

Unassigned

Reporter

codehaus

Triage

None

Fix versions

Affects versions

Components

Priority

High
Configure