When migrating layergroups from 2.3.x Web Admin UI can fail

Description

Geoserver 2.3.x allows some layergroups configuration that when migrated to 2.4.x make the UI fail on LayerGroups and Layer Preview sections.
For example this may happen when some layers and/or styles included in the layergroup are removed, but the layergroup is not.

Environment

None

Activity

Show:
codehaus
April 10, 2015, 4:02 PM

CodeHaus Comment From: aaime - Time: Sun, 2 Feb 2014 04:11:18 -0600
---------------------
<p>Wow... this group definition is seriously broken, none of the layers is populated? Wondering how it could have worked with 2.3.x?</p>

codehaus
April 10, 2015, 4:02 PM

CodeHaus Comment From: mbarto - Time: Sun, 2 Feb 2014 07:13:13 -0600
---------------------
<p>This is probably the effect of removing layers and styles that the layergroup is composed of.

I think the startup code should simply remove the empty layers/styles completely (giving some warning during startup).</p>

codehaus
April 10, 2015, 4:02 PM

CodeHaus Comment From: jonathan_wcc - Time: Mon, 10 Feb 2014 05:54:38 -0600
---------------------
<p>I can confirm I was getting this and deleting the guilty LayerGroups fixed it.</p>

codehaus
April 10, 2015, 4:02 PM

CodeHaus Comment From: aaime - Time: Sat, 15 Feb 2014 10:53:14 -0600
---------------------
<p><a href="https://github.com/geoserver/geoserver/pull/477" class="external-link" rel="nofollow">https://github.com/geoserver/geoserver/pull/477</a></p>

Andrea Aime
February 15, 2017, 11:46 AM

Mass closing all resolved issues not modified in the last 4 weeks

Assignee

Unassigned

Reporter

codehaus

Triage

None

Fix versions

Affects versions

Components

Priority

Low
Configure