Update documentation about Java versions

Description

Currently our documentation makes users to believe that they can’t run Geoserver with Java 8 at all which makes them worried. We should mention that Geoserver (at least 2.6, 2.7) runs with Java 8 even it may not build with it, and that Java 8 will soon be a requirement. Affect at least documents:

http://docs.geoserver.org/stable/en/user/installation/war.html
http://docs.geoserver.org/stable/en/user/production/java.html#production-java

Environment

None

Status

Assignee

Unassigned

Reporter

Jukka Rahkonen

Triage

None

Fix versions

Affects versions

None

Components

Priority

Medium
Configure