SLD renders lines in which are discontinuous (missing segments)

Description

I am new to geoserver I have downloded osm.xml data and convert it to sql using osm2pgsql and then imported that postgis data to geoserver .When I try to render the roads using xml coded sld it gives discontinuous lines with missing lines segments and tile caching shows an error.
1) osm data
http://download.geofabrik.de/europe/germany/hamburg.html

Environment

geoserver 2.8 java 1.7 postgreSql 9.4

Activity

Show:
Darshan Lingegowda
November 2, 2015, 1:10 PM

The java error and the tile caching error is resolved .I have styled the sld to render the map feature highway that comes under the roads with all its principle tags .But I have noticed that the primary ,secondary ,teritary lines rendered are disjoint with gaps in between instead of a continuous line ,this problem is there at all zoom levels and I am unable to figure out what is the error

Brad Hards
November 2, 2015, 8:04 PM

Could you say what java error (not mentioned in your original description) and what tile caching error (not described in any detail) you had, and what you did to resolve them? Perhaps that is relevant to the other issue(s) you are experiencing.

For the styling issue, perhaps that would be better as a discussion on the geoserver-users mailing list.

Darshan Lingegowda
November 3, 2015, 10:00 AM

The java error

is attached and the same error was show every time I tried to open cached layers under map tiles cache but I read online this could be because of GC memory allocation or java installation problem , so I reinstalled java and changed GC memory allocation and the error was resolved.

Andrea Aime
February 15, 2017, 11:47 AM

Mass closing all resolved issues not modified in the last 4 weeks

Not a Bug

Assignee

Unassigned

Reporter

Darshan Lingegowda

Triage

None

Fix versions

None

Affects versions

Components

Priority

Highest
Configure