GeoServer REST Layer not working

Description

@First read this issue:
https://osgeo-org.atlassian.net/browse/GEOS-7384

@After
Dear Andrea!

I think that is GeoServer REST problem. I use 1.7 geoserver-manager with 2.8.0 geoserver version, and the publish and save working. If i use 1.7 geoserver-manager with 2.8.1 or 2.8.2 geoserver versions, its not working. I post the following xml string to

http://localhost:8000/geoserver/rest/workspaces/-workspacename-/datastores/-datastorename-/featuretypes

the xml string:

<featureType>
<enabled>true</enabled>
<metadata>
<entry key="JDBC_VIRTUAL_TABLE">
<virtualTable>
<name>DEMO_EK_TABLA_GAZID</name>
<sql>select * from EK_TABLA_2015 where gazid in ( 1000821232, 1008733450, 1001179664, 1003192911,
1001261589, 1003164280, 1001179675, 1000671785, 1016139884, 1001178788, 1004285261, 1004508337,
1002119698, 1001179411, 1005500099, 1002986113, 1008644141, 1001179181, 1001178755, 1011016991,
1004867090, 1002931047, 1001178832, 1000821001, 1001179510, 1000671718, 1000821638, 1001179345,
1003860311, 1004603904, 1001211870, 1004838164, 1001178931, 1001179378, 1001179554, 1001179642,
1000821430, 1001179532, 1003760387)
</sql>
<keyColumn>GAZID</keyColumn>
<geometry>
<name>GEOM</name>
<type>Geometry</type>
<srid>23700</srid>
</geometry>
<geometry>
<name>GEOM_SIMPLE</name>
<type>Geometry</type>
<srid>23700</srid>
</geometry>
<geometry>
<name>GEOM_CENTER</name>
<type>Geometry</type>
<srid>23700</srid>
</geometry>
</virtualTable>
</entry>
</metadata>
<keywords/>
<metadataLinks/>
<attributes/>
<nativeName>DEMO_EK_TABLA_GAZID</nativeName>
<name>DEMO_EK_TABLA_GAZID</name>
<title>DEMO_EK_TABLA_GAZID</title>
<nativeCRS>EPSG:23700</nativeCRS>
<srs>EPSG:23700</srs>
<nativeBoundingBox>
<minx>400000.0</minx>
<maxy>360000.0</maxy>
<maxx>950000.0</maxx>
<miny>40000.0</miny>
<crs>EPSG:23700</crs>
</nativeBoundingBox>
</featureType>

Its oke, but after save i have only one geometry in virtualtable(in featuretype.xml), the following:

<geometry>
<name>GEOM_CENTER</name>
<type>Geometry</type>
<srid>23700</srid>
</geometry>

(All time save the last from the VTGeometryEncoder list)
It would be necessary for the proper operation of all three measurement geometries. I need the following code in the featuretype.xml:

<geometry>
<name>GEOM</name>
<type>Geometry</type>
<srid>23700</srid>
</geometry>
<geometry>
<name>GEOM_SIMPLE</name>
<type>Geometry</type>
<srid>23700</srid>
</geometry>
<geometry>
<name>GEOM_CENTER</name>
<type>Geometry</type>
<srid>23700</srid>
</geometry>

This is the problem/bug, after REST post not saving the all attributes in featuretype.xml. Its not working with 2.8.1 and 2.8.2 geoserver versions.

I use:
Oracle DB
Oracle NG datastore
Java 1.7
GeoServer 2.8.2 and/or 2.8.1
1.7-SNAPSHOT geoserver-manager api

Environment

None

Status

Assignee

Unassigned

Reporter

Orosz Gabor

Triage

None

Fix versions

Affects versions

2.8.1
2.8.2

Components

Priority

Medium
Configure