Problem with style for wind direction data

Description

Hi all,
I have published one band raster data representing wind direction like Image Mosaics.
They are in EPSG:4258 with a BBOX [-16.058210564139415,32.96955965348397,39.2896078071642,80.02803653793978]

I create a style that represents the wind direction with arrows, in function of the pixel values (see attached file wind_style_1.xml).

When i call the layer with this WMS
"127.0.0.1/geoserver/wind/wms?port=8181&LAYERS=id1359s011011r000-europe&TRANSPARENT=TRUE&VERSION=1.1.0&TIME=2016-04-29T10%3A06%3A00.000Z&TILED=true&SERVICE=WMS&REQUEST=GetMap&STYLES=&FORMAT=image%2Fpng&SRS=EPSG%3A4258&BBOX=29,33,74,78&WIDTH=256&HEIGHT=256"
I expect to get an empty image for that BBOX and for that TIME, but I get an unexpected exception (see the full stack trace in "error.txt" file in attach).

I replaced in the first style "TextSymbolizer" with "PointSymbolizer" like in wind_style_2.xml but the issue still remain.
The problem happen only for the styles linked. If I use a style with the RULE "RasterSymbolizer" I have no exception for the same layer.

If I publish the same raster with the same style In a geoserver version 2.7.1 that I use for other projects it works properly (this geoserver is running with 1.7.0_65 (OpenJDK 64-Bit Server VM) and Postgresql server version 9.2).

Environment

OS Ubuntu 15.10
JVM version 1.7.0_80 (Java HotSpot(TM) 64-Bit Server VM)
Postgresql server version 9.4
JNDI connection pool

Assignee

Unassigned

Reporter

matteo rivola

Triage

None

Fix versions

None

Affects versions

Components

Priority

Medium
Configure