Uploaded image for project: 'GeoServer'
  1. GEOS-7682

Layers with the same name from different workspaces cannot be distinguished in a layers.xml call

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: 2.9.1
    • Fix Version/s: 2.13-beta
    • Component/s: REST
    • Labels:
      None

      Description

      I've configured two layers with the same name 'roads' in two different ws: 'sf' and 'sf2', this is what I get from

      http://localhost:8080/geoserver/rest/layers.xml
      
      <layers>
      <layer>
      <name>roads</name>
      <atom:link xmlns:atom="http://www.w3.org/2005/Atom" rel="alternate" href="http://localhost:8080/geoserver/rest/layers/roads.xml" type="application/xml"/>
      </layer>
      <layer>
      <name>roads</name>
      <atom:link xmlns:atom="http://www.w3.org/2005/Atom" rel="alternate" href="http://localhost:8080/geoserver/rest/layers/roads.xml" type="application/xml"/>
      </layer>
      <layer>
      </layers>
      

      there is no way to tell them apart

        Attachments

          Issue links

            Activity

              People

              • Assignee:
                jody.garnett Jody Garnett
                Reporter:
                elpaso Alessandro Pasotti
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: