Error "Field 'latLonBoundingBox' is required" when creating layer

Description

When I create layer (any shapefile) I click "Compute from data" to fill native bbox and "Compute from native bounds" to fill Lat/Lon bbox. I've always filled bboxes like that. But now I've noticed that after I click "Compute from native bounds" the error is appearing - Field 'latLonBoundingBox' is required, though all fields are getting filled and layer then can be saved without any errors. Is it some validation issue?

I've attached my bbox settings.

Environment

None

Activity

Show:
Andrea Aime
September 30, 2016, 4:16 PM

I can however confirm the second report : https://osgeo-org.atlassian.net/browse/GEOS-7777

Ben Caradoc-Davies
October 1, 2016, 3:17 AM

This could be a locale issue: the bounding box given by Sergey uses commas (",") as the decimal separator.

Sergey, what happens if you manually replace the commas (",") with full stops (".") and try to submit the page?

Sergey Kolosov
October 1, 2016, 6:12 AM

Ben, there is no problem with submitting the page. When I click "Compute from native bounds", error is immediately appeared. Though "Lat/Lon bounding box" is getting filled - right after click too. So my one click produces error and fills bbox. Then I click Save button - and page is submitted OK regardless of the error. Full stops (".") produces another 4 error about type mismatch.

And one thing - the error is appeared on the top of the page. So you should scroll to see it.

Andrea Aime
October 1, 2016, 9:44 AM

Hi Sergery, yes, that's what I did... however, I've tried again and now I see the issue... oh well

Andrea Aime
February 15, 2017, 11:48 AM

Mass closing all resolved issues not modified in the last 4 weeks

Fixed

Assignee

Andrea Aime

Reporter

Sergey Kolosov

Triage

None

Fix versions

Affects versions

Priority

Medium
Configure