We're updating the issue view to help you get more done. 

VT: incorrect version of java-vector-tiles is being pulled in (1.0.8 vs 1.0.9)

Description

Correct version is 1.0.9

although extension/vectortiles's pom.xml depends on java-vector-tiles 1.0.9

<dependency>
<groupId>no.ecc.vectortile</groupId>
<artifactId>java-vector-tile</artifactId>
<version>1.0.9</version>
</dependency>

version 1.0.8 is being bundled in the .zip. This is likely due to a 1.0.8 in community/script/groovey/pom.xml

https://github.com/boundlessgeo/geoserver/blob/ead2a5650e4877cdddab91bb617f4c5e4492c4c9/src/community/script/groovy/pom.xml

<dependency>
<!-- this dependency taken from geoscript-groovy pom but upgraded to 1.0.8 -->
<groupId>no.ecc.vectortile</groupId>
<artifactId>java-vector-tile</artifactId>
<version>1.0.8</version>
<!-- Exclude protobuf here so gt-geobuf can pull in a more recent version -->
<exclusions>
<exclusion>
<groupId>com.google.protobuf</groupId>
<artifactId>protobuf-java</artifactId>
</exclusion>
</exclusions>
</dependency>

Environment

None

Status

Assignee

Unassigned

Reporter

David Blasby

Triage

None

Fix versions

Affects versions

2.9.1
2.9.2

Priority

Medium