Uploaded image for project: 'GeoServer'
  1. GeoServer
  2. GEOS-7870

GeoFence: zipped module contains useless/harmful postgis jars

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: 2.9.2
    • Fix Version/s: 2.9.3, 2.10.1, 2.11-beta
    • Component/s: None
    • Labels:
      None

      Description

      The zip file for geofence-server contains 2 postgis jars.
      They are useless, in that at the moment geofence-server uses an H2 DB.
      Furthermore, they are harmful, since postgis-stubs-1.3.3.jar duplicates the PGConnection interface, also declared in the postgresql jdbc jar. The version in stubs anyway is missing a method, so if this jar is loaded before the postgresql one, it will throw
      {{java.lang.NoSuchMethodError: org.postgresql.core.BaseConnection.getPreferQueryMode()Lorg/postgresql/jdbc/PreferQueryMode;
      }} and GeoServer will not start.

        Attachments

          Activity

            People

            • Assignee:
              etj Emanuele Tajariol
              Reporter:
              etj Emanuele Tajariol
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: