Slow startup of GeoServer with many layers

Description

Very slow startup of GeoServer was found in some cases. It seems this occurs at ver 2.9.x or 2.10.x

Belows are reportes case:

1. When we tried to load around 9,000 layers from PostGIS using GeoServer 2.9.x or 2.10.x, it took almost 1 hour as opposed to 30 seconds with GeoServer 2.8.5. Current system environments are like below:

2. I have the same problem as described in [1] – I am running GeoServer under Tomcat with a lot of georeferenced maps ( about 65 000 ) and it takes very long time to start - about 3-4 hours.
The problem seems to be in that GeoServer is checking all of those resources one by one each time it starts..
My question is: Is there any way to disable these checks? Or do them only one a month or so? https://sourceforge.net/p/geoserver/mailman/message/35525607/

3. Following the welcome improvement in 2.8.0 for the faster loading of Oracle layer configurations, it seems that this enhancement is not as noticeable in subsequent versions (e.g. 2.9.x and the current 2.10 build).  Does anyone know why this might be? The difference in startup times is significant: 15 seconds as opposed to 15 minutes! http://osgeo-org.1560.x6.nabble.com/Return-to-slow-loading-of-Oracle-layers-td5280567.html

[1] http://osgeo-org.1560.x6.nabble.com/GeoServer-Slow-to-Start-with-Lots-of-Namespaces-td5068101.html

Environment

None

Status

Assignee

Andrea Aime

Reporter

Sanghee Shin

Triage

None

Fix versions

Affects versions

None

Priority

Medium
Configure