Uploaded image for project: 'GeoServer'
  1. GEOS-8001

WMTS capabilities does not include a style for default style on vector layers

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: 2.10.1, 2.10.2
    • Fix Version/s: 2.11-RC1
    • Component/s: GWC
    • Labels:
      None

      Description

      Look in the WMTS capabilities doc of a default GeoServer install and look for topp:states, only two of the three styles are listed:

      <Style>
      <ows:Identifier>polygon</ows:Identifier>
      <LegendURL width="20" height="20" format="image/png" xlink:href="http://192.168.0.13:8080/geoserver/ows?service=WMS&request=GetLegendGraphic&format=image%2Fpng&width=20&height=20&layer=topp%3Astates&style=polygon"/>
      </Style>
      <Style>
      <ows:Identifier>pophatch</ows:Identifier>
      <LegendURL width="81" height="80" format="image/png" xlink:href="http://192.168.0.13:8080/geoserver/ows?service=WMS&request=GetLegendGraphic&format=image%2Fpng&width=81&height=80&layer=topp%3Astates&style=pophatch"/>
      </Style>

      The default style "population" is missing, so you can't use it in QGIS (for example).

        Attachments

          Activity

            People

            • Assignee:
              ianturton Ian Turton
              Reporter:
              ianturton Ian Turton
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: