Uploaded image for project: 'GeoServer'
  1. GEOS-8013

GetFeature GET request with 3d bbox fails to parse

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.10.3, 2.11-RC1
    • Component/s: None
    • Labels:
      None

      Description

      When using the following configuration, a POST requests seems to result in Geoserver loading all features from database and performing the BBOX filter internally.

      Environment:

      • Postgresql: "PostgreSQL 9.2.4, compiled by Visual C++ build 1600, 64-bit"
      • Postgis: "POSTGIS="2.0.3 r11132" GEOS="3.3.8-CAPI-1.7.8" PROJ="Rel. 4.8.0, 6 March 2012" GDAL="GDAL 1.9.2, released 2012/10/08" LIBXML="2.7.8" LIBJSON="UNKNOWN" RASTER"
      • Geoserver 2.9.1 and 2.10.1
      • JVM 1.8.0_112

      Table creation:

       
      CREATE TABLE table_wmk_lijn_2016
      (
        stdx double precision,
        stdy double precision,
        stdz double precision,
        meas_info text,
        quality double precision,
        fid integer NOT NULL DEFAULT nextval('table_wmk_lijn_2016_seq'::regclass),
        objecttype text NOT NULL,
        date_recorded timestamp with time zone,
        date_modified timestamp with time zone,
        username text,
        comment_cm text,
        height text,
        the_geom geometry(LineStringZ,7415),
        objectstatus text,
        CONSTRAINT table_wmk_lijn_2016_pkey PRIMARY KEY (fid),
        CONSTRAINT enforce_dims_geom CHECK (st_ndims(the_geom) = 3),
        CONSTRAINT enforce_geotype_geom CHECK (geometrytype(the_geom) = 'LINESTRING'::text OR the_geom IS NULL),
        CONSTRAINT enforce_srid_geom CHECK (st_srid(the_geom) = 7415)
      )
      

      A GET request results in the following error:

      http://myserver.com:8080/geoserver/ows?SERVICE=WFS&VERSION=1.1.0&REQUEST=GetFeature&SRSNAME=EPSG:7415&TYPENAME=inl:table_wmk_lijn_2016&BBOX=86620.02749999995,437105.71499999886,86787.92249999997,437198.7449999985,EPSG:7415
      
       
      <ows:ExceptionReport xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:ows="http://www.opengis.net/ows" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="1.0.0" xsi:schemaLocation="http://www.opengis.net/ows http://geoserver-c.cyclomedia.com:8080/geoserver/schemas/ows/1.0.0/owsExceptionReport.xsd">
        <ows:Exception exceptionCode="NoApplicableCode">
          <ows:ExceptionText>org.opengis.geometry.MismatchedDimensionException: Argument "Amersfoort / RD New + NAP height" has 3 dimensions, while 2 was expected.
      Argument "Amersfoort / RD New + NAP height" has 3 dimensions, while 2 was expected.</ows:ExceptionText>
        </ows:Exception>
      </ows:ExceptionReport>
      

        Attachments

          Activity

            People

            • Assignee:
              aaime Andrea Aime
              Reporter:
              aaime Andrea Aime
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: