Priority tag not validating

Description

Adding the priority tag resulted in validation of:
line 63: cvc-complex-type.2.4.a: Invalid content was found starting with element 'PropertyName'. One of '{"http://www.opengis.net/ogc":expression}' is expected.

SLD that causes the problem is:
<Rule>
<MaxScaleDenominator>250000</MaxScaleDenominator>
<TextSymbolizer><Label><ogcropertyName>name</ogcropertyName></Label><Font><CssParameter
name="font-family">Arial</CssParameter><CssParameter
name="font-size">11</CssParameter></Font><LabelPlacement><PointPlacement><AnchorPoint><AnchorPointX>0</AnchorPointX><AnchorPointY>0</AnchorPointY></AnchorPoint><Displacement><DisplacementX>0</DisplacementX><DisplacementY>10</DisplacementY></Displacement></PointPlacement></LabelPlacement><Fill><CssParameter
name="fill">#000000</CssParameter></Fill>
<Priority><PropertyName>year</PropertyName></Priority>
</TextSymbolizer>
</Rule>

If I remove PropertyName from Priority it validates (but not much use).

My SLD header is:
<StyledLayerDescriptor xmlns="http://www.opengis.net/sld" xmlns:ogc="http://www.opengis.net/ogc" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.opengis.net/sld http://schemas.opengis.net/sld/1.0.0/StyledLayerDescriptor.xsd"
version="1.0.0">

I looked for Priority in teh xsd but didnt find it.

Environment

Windows and Linux

Status

Assignee

Unassigned

Reporter

Phil Scadden

Triage

Fix versions

None

Affects versions

Priority

Medium
Configure