Black image when zoomed out - using ImageMosaic plugin

Description

1. Have a directory of 80 ish- GeoTIFFS (JPEG-compressed, tiled, with internal overviews) in EPSG:5111.
2. Create Stores - ImageMosaic and select that catalogue with files so necessary shape + .properties file gets created.

Have tried various settings, using default Raster-style. Have tried to connect to WMS through QGIS (latest) and OpenLayers - samme issue. The data loads fine from the detailed level and up untill approx 1:13400 - when I zoom more out: For instance: 1:214400 - I only get a black box covering the bounding box. It seems at a certain level the ImageMosaic eiter stops requesting for that zoom-level or does not load anything. When I open the GeoTIFFs locally I can zoom "all the way out" and see that the topmost overview is NOT black.

Possible reasons? Attached is the generated .properties from ImageMosaic.

  • The Levels= is generated wrong? At the topmost level it should have a higher number=

  • ImageMosaic struggles with certain Coordinate systems (for instance EPSG:5111)?

  • ImageMosaic can not read small overviews (highest level is 64x64 pixels) - resolution of each GeoTIFF is X: 16384 Y: 16384 Bands: 3.

Have tried googling alot, but cant seem to find a good solution or workaround. I can not use a BIGTIFF since I need JPEG-compression, and the file will be larger than 4GB if I have to create 1 file

Environment

Ubuntu with:

GeoServer Version
2.10.2
Git Revision
2d2587f96b7d74e55476983427039c41cdd55ad9
Build Date
23-Feb-2017 00:06
GeoTools Version
16.2 (rev 0339ee65aacd615538ebc719d4fd7c65568d18de)
GeoWebCache Version
1.10.2 (rev 1.10.x/521b1bbc544e68dc25f154293f3b877797ab488f)

Status

Assignee

Unassigned

Reporter

Sigbjørn Herstad

Triage

None

Fix versions

None

Affects versions

Components

Priority

Medium
Configure