imageio-ext-gdal-bindings-xxx.jar not available in geoserver-2.x.x-gdal-plugin.zip anymore since 2.10

Description

As seen in title: imageio-ext-gdal-bindings-xxx.jar not available in geoserver-2.x.x-gdal-plugin.zip anymore since 2.10

We are using the gdal plugin to test ecw's internally for some Geoserver versions.

Since 2.10 though the (apparently needed) imageio-ext-gdal-bindings-1.9.2.jar is NOT available anymore in the geoserver-2.x.x-gdal-plugin.zip...

The problem you will see is described here too:
http://osgeo-org.1560.x6.nabble.com/GeoServer-2-11-0-is-not-starting-after-installing-GDAL-plugin-Windows-Tomcat-td5315288.html

During startup you will see something like:

Failed to instantiate [org.geowebcache.io.ImageIOInitializer]: Factory method 'getInstance' threw exception; nested exception is java.util.ServiceConfigurationError: javax.imageio.spi.ImageReaderSpi: Provider it.geosolutions.imageio.plugins.arcbinarygrid.ArcBinaryGridImageReaderSpi could not be instantiated

In all my geoserver/plugin backups, the (attached) jar was available in the GDAL plugin zip till version 2.9.x
After 2.10.x it disappeared from the zip, giving rise to above problem.
As soon as you copy this jar to the lib dir of geoserver all is fine again.

Is this a packaging problem?
Or maybe a licensing problem?

This makes the upgrade process a little less smooth

Thanks for looking into this or providing any info.

Environment

All (though we are running on Windows Server)

Status

Assignee

Torben Barsballe

Reporter

Richard Duivenvoorde

Triage

None

Fix versions

Affects versions

Components

Priority

Medium
Configure