Wrong error from WCS 2.0.1 with &predictor=FloatingPoint

Description

Request for testing:

http://localhost:8080/geoserver/wcs?service=WCS&version=2.0.1&request=GetCoverage&CoverageID=nurc__mosaic&format=image/geotiff&geotiff:compression=LZW&geotiff:predictor=FloatingPoint

Result:
<ows:Exception exceptionCode="PredictorInvalid" locator="FloatingPoint">
<ows:ExceptionText>Invalid Predictor provided ]</ows:ExceptionText>
</ows:Exception>

Predictor is not invalid, thus ecxeptionCode value should be "PredictorNotSupported".
Reference: Table 3 – Exception codes for GeoTIFF paremeters in GML Application Schema - Coverages - GeoTIFF Coverage Encoding Profile standard.

Environment

None

Status

Assignee

Unassigned

Reporter

Jukka Rahkonen

Triage

None

Fix versions

None

Affects versions

None

Components

Priority

Medium
Configure