Rendering error with HSQLDB EPSG database

Description

I tried to render a postgis datasource utilizing "gt-epsg-hsql-2.7.1.jar" (plus dependencies), with data from BOLIVIA and it renders in a wrong way, the output image is really wrong!.
But when i use a Shapefile DataStore, everything seems to work correctly, the output is right.

I attached 5 files:

  • MapDemo.java, the code that use for my rendering
    * countries_shp.png, the IMAGE produced using a shapefile data source (barrios.shp)
    * countries_pg.png, the IMAGE produced using a POSTGIS data source (barrios)
    >>>> For both files above take a look to the red rectangle, countries_shp.png shows the correct location of Bolivia.
    * bolivia_shp.jpeg, this is the output of BARRIOS data source from postgres (WRONG).
    * bolivia_shp.jpeg, this is the output of BARRIOS data source from a shapefile (RIGHT)

P.S.
The postgis data has been created using the "pgsql2shp" tool of postgis.
The countries datasource "countries.shp" is a shapefile.

Environment

None

Activity

Show:
codehaus
April 10, 2015, 3:09 PM

CodeHaus Comment From: mikevegap - Time: Thu, 26 May 2011 15:43:16 -0500
---------------------
I forgot to say that

I used "gt-epsg-wkt-2.7.1.jar" and it works perfectly.

codehaus
April 10, 2015, 3:09 PM

CodeHaus Comment From: aaime - Time: Thu, 26 May 2011 16:47:32 -0500
---------------------
You did not force the epsg database in lon/lat order. Please see the user mailng list archives, I've just answered a similar question there

codehaus
April 10, 2015, 3:09 PM

CodeHaus Comment From: mikevegap - Time: Thu, 26 May 2011 17:35:10 -0500
---------------------
Thanks Andrea, it works perfectly.

Andrea Aime
February 15, 2017, 11:44 AM

Mass closing all resolved issues not modified in the last 4 weeks

Fixed

Assignee

Unassigned

Reporter

codehaus

Triage

None

Fix versions

Affects versions

Priority

Medium
Configure