tutorial / eclipse doc quirk

Description

Hi Osgeo-team,

I recently followed the instructions at geotools.org using the
quickstartlink for eclipse (
http://docs.geotools.org/latest/userguide/tutorial/quickstart/eclipse.html - http://docs.geotools.org/latest/userguide/tutorial/quickstart/eclipse.html
) . There I noticed a failure in the examplecode (the code does not work
proper):

//-codebeginning
MapContent map = new MapContent();

Style style = SLD.createSimpleStyle(featureSource.getSchema());
Layer layer = new FeatureLayer(featureSource, style);
map.addLayer(layer);

// Now display the map
JMapFrame.showMap(map);
//codeend

Eclipse wants to cast map to MapContext. When I enter "geotools tutorial"
in google I get a tutorial on your site with the correct code (using
MapContext). Maybe you could correct the code at geotools at the
quickstart-link. People who want to start with geotools mostlikely start
with it using this quickstartlink . A false code doesn't cause a lot of
Motivation <img class="emoticon" src="https://jira.codehaus.org/images/icons/emoticons/wink.gif" height="16" width="16" align="absmiddle" alt="" border="0"/> .

Regards Marvin, Vienna AUT
marvinmccutchan@yahoo.de

Environment

None

Activity

Show:
codehaus
April 10, 2015, 2:57 PM

CodeHaus Comment From: mbedward - Time: Wed, 29 Feb 2012 17:47:31 -0600
---------------------
It sounds like you were looking at the latest Quickstart tutorial, but using an older version of GeoTools (e.g. 2.7). Is that possible ?

The tutorial should work as advertised with GeoTools 8 milestones.

Assignee

Unassigned

Reporter

codehaus

Triage

None

Components

Priority

Medium
Configure