maintenance Tutorials link is broken

Description

The link from http://docs.geotools.org/ to
http://docs.geotools.org/maintenance/tutorials/
is broken. User-Guide and FAQ's are fine-

Environment

None

Activity

Show:
Jody Garnett
June 3, 2019, 1:35 AM

Ah does not have “userguide” in the URL. Can I ask which specific link is broken on that page?

Brad Hards
June 3, 2019, 3:23 AM

In the `User Guide` section, we have HTML like:

```
`Tutorials <http://docs.geotools.org/latest/userguide/tutorial/>`_ ( `stable <http://docs.geotools.org/stable/tutorials/>`_ | `maintenance <http://docs.geotools.org/maintenance/tutorials/>`_ )
Step by step tutorials introducing both GeoTools and geospatial concepts for Java developers.
```

The `maintenance <http://docs.geotools.org/maintenance/tutorials/>` part is bad. The stable link (`tutorials` vs `tutorial`) works but is not consistent with `latest`.

So I think it probably should be `userguide/tutorial/` in each case:
```
`Tutorials <http://docs.geotools.org/latest/userguide/tutorial/>`_ ( `stable <http://docs.geotools.org/stable/userguide/tutorial/>`_ | `maintenance <http://docs.geotools.org/maintenance/userguide/tutorial/>`_ )
Step by step tutorials introducing both GeoTools and geospatial concepts for Java developers.
```

Andrea Aime
January 4, 2020, 5:29 PM

The link seems to be working now, has this been fixed? Cannot see a commit for this ticket.

Jody Garnett
January 4, 2020, 7:01 PM

Checking here shows it is not fixed yet.

Jody Garnett
January 4, 2020, 7:03 PM

Assignee

Jody Garnett

Reporter

Frank Gasdorf

Triage

None

Components

Priority

Medium
Configure