Add check for functions deprecated in PostGIS 2.1.0

Description

ST_Force_2D() and ST_Estimated_Extent() became deprecated signatures in PostGIS 2.1.0 but are still being used in the PostGISDialect class, this generates WARNING and CONTEXT errors in PostgreSQL.

Suggest adding a check for PostGIS versions 2.1.0 and above where ST_Force2D() and ST_EstimatedExtent() should be used instead.

Environment

  • GeoServer 2.8.2

  • PostgreSQL 9.4.5

  • PostGIS 2.2.1

Activity

Show:
Shane St Clair
March 17, 2016, 11:21 PM

I can implement this, pull request coming soon.

Shane St Clair
March 18, 2016, 6:39 AM
Fixed

Assignee

Unassigned

Reporter

Ti Marner

Triage

None

Components

Priority

Medium
Configure