Uploaded image for project: 'GeoTools'
  1. GeoTools
  2. GEOT-5395

Build failure in gt-grib with -Dnetcdf.version=4.6.4 or later

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: 15-beta2
    • Fix Version/s: 15.1, 16-M0
    • Component/s: coverage-multidim
    • Labels:
      None

      Description

      GeoTools master currently uses <netcdf.version>4.6.2</netcdf.version>. If netcdf.version is upgraded to 4.6.4 or later, the build fails. For example, building with -Dnetcdf.version=4.6.4 results in:

      Tests in error: 
        GribTest.testGribImage:199->testGribFile:237 » PointOutsideCoverage Coordinate...
        GribUtilitiesTest>GribTest.testGribImage:199->GribTest.testGribFile:237 » PointOutsideCoverage
      

      The build passes fine with -Dnetcdf.version=4.6.3.

        Attachments

          Issue links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                bencaradocdavies Ben Caradoc-Davies
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: