Upgrade httpclient

Description

Currently Commons HttpClient 3.x is in use, this has various shortcomings as well as number of weaknesses and security issues and has been EOL for some years.

Upgrading to 4.x is non-trivial, because the api is incompatible, see eg. http://httpcomponents.10934.n7.nabble.com/migrating-from-3-1-gt-4-1-td14273.html
but necessary to resolve the SSL/TLS issues such as CVE-2014-3577, CVE-2012-5783, CVE-2012-6153

Environment

None

Assignee

Unassigned

Reporter

Mark Prins

Triage

None

Components

Affects versions

Priority

Medium
Configure