Batik does not ship ServiceSPI files in Maven distro

Description

Batik does not include META-INF/services/ files in the maven artifacts. See https://issues.apache.org/jira/browse/BATIK-1005 for more discussion. This leads to an NPE when using the Batik renderer in GeoTools (see https://gis.stackexchange.com/questions/263653/geotools-rendering-map-with-sld-to-svg for an example) it seems that simply upgrading to 1.9 is not sufficient and we need to actually add the required files in to our build.

Upgrading to 1.9 would probably be a good idea too.

Environment

None

Assignee

Ian Turton

Reporter

Ian Turton

Triage

Components

Fix versions

Affects versions

Priority

Medium
Configure