Update MySql jdbc driver to a newer version

Description

MySql Jdbc driver currently used by geotools is pretty outdate (v5.1.17) consider upgrading to a newer version

Environment

None

Status

Assignee

Unassigned

Reporter

Nikolaos Pringouris

Triage

Components

Fix versions

Priority

Medium
Configure