gt-ogr - support gdalalljni JNI bindings (GDAL 2.3.0)

Description

As of GDAL 2.3.0, the GDAL JNI bindings (formerly libgdaljni and libgdalconstjni) have been combined into libgdallalljni. This means that gt-ogr will be incompatible with GDAL 2.3.0 and newer.

Environment

None

Assignee

Unassigned

Reporter

Torben Barsballe

Triage

None

Components

Fix versions

Priority

Medium
Configure