shapefile -- cannot build

Description

maven jar:install or mvn install in plugin/shapefile causes the following exception in org.geotools.data.shapefile.ShapefileReadWriteTest:

Testcase: testConcurrentReadWrite(org.geotools.data.shapefile.ShapefileReadWriteTest): Caused an ERROR
C:\DOCUME~1\DAVIDB~1\LOCALS~1\Temp\test-shp39360.prj (The requested operation cannot be performed on a file with a user-mapped section open)
java.io.FileNotFoundException: C:\DOCUME~1\DAVIDB~1\LOCALS~1\Temp\test-shp39360.prj (The requested operation cannot be performed on a file with a user-mapped section open)
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
at org.geotools.data.shapefile.ShapefileDataStore.copyAndDelete(ShapefileDataStore.java:1109)
at org.geotools.data.shapefile.ShapefileDataStore.createSchema(ShapefileDataStore.java:802)
at org.geotools.data.shapefile.ShapefileReadWriteTest.test(ShapefileReadWriteTest.java:174)
at org.geotools.data.shapefile.ShapefileReadWriteTest.test(ShapefileReadWriteTest.java:152)
at org.geotools.data.shapefile.ShapefileReadWriteTest.testConcurrentReadWrite(ShapefileReadWriteTest.java:132)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

Environment

None

Activity

Show:
codehaus
April 10, 2015, 2:51 PM

CodeHaus Comment From: jeichar@refractions.net - Time: Wed, 5 Apr 2006 13:05:26 -0500
---------------------
does this happen on 2.2 and trunk or just trunk?

codehaus
April 10, 2015, 2:51 PM

CodeHaus Comment From: dblasby - Time: Wed, 5 Apr 2006 13:26:10 -0500
---------------------
I cannot even get trunk to start building for me so I have no idea if it works on trunk or not.

codehaus
April 10, 2015, 2:51 PM

CodeHaus Comment From: dblasby - Time: Wed, 5 Apr 2006 13:27:55 -0500
---------------------
I clean out all my temporary files, which allowed it to build last time, but no go this time.

codehaus
April 10, 2015, 2:51 PM

CodeHaus Comment From: jeichar@refractions.net - Time: Mon, 29 May 2006 16:40:32 -0500
---------------------
I beleive this is resolved. Is it not?

Assignee

Unassigned

Reporter

codehaus

Triage

None

Components

Priority

Highest
Configure