Uploaded image for project: 'GeoServer'
  1. GEOS-8431

WFS 2.0 GetFeature fails on filter with TimePeriod

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.13-beta
    • Component/s: WFS
    • Labels:

      Description

      This filter (put in a GET request) fails to parse due to a class cast exception:

      <fes:Filter xmlns:ns44="http://cite.opengeospatial.org/gmlsf"
      	xmlns:wfs="http://www.opengis.net/wfs/2.0" xmlns:fes="http://www.opengis.net/fes/2.0">
      	<fes:During>
      		<fes:ValueReference xmlns:tns="http://cite.opengeospatial.org/gmlsf">tns:dateTimeProperty
      		</fes:ValueReference>
      		<gml:TimePeriod xmlns:gml="http://www.opengis.net/gml/3.2"
      			frame="http://www.iso.org/iso/iso8601" gml:id="TP01">
      			<gml:beginPosition>2006-06-28T04:08:00Z</gml:beginPosition>
      			<gml:endPosition>2009-06-28T06:08:00Z</gml:endPosition>
      		</gml:TimePeriod>
      	</fes:During>
      </fes:Filter>
      

        Attachments

          Issue links

            Activity

              People

              • Assignee:
                aaime Andrea Aime
                Reporter:
                aaime Andrea Aime
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: